Authentication failures

Incident Report for Finale Inventory

Resolved

Login is resolved for all customers, in case of questions, please submit a ticket to our support team.
Posted Mar 30, 2026 - 15:39 UTC

Identified

We are aware of an authentication issue with the Descartes Global Authentication Portal that is preventing some customers from accessing the Finale Inventory application. These errors are intermittent, so, we suggest to keep trying to login until it succeeds. Our teams are actively working on a fix, and we apologize for the inconvenience.
Posted Mar 30, 2026 - 14:40 UTC