Issue saving entities (orders, products, etc) due to library upgrade

Incident Report for Finale Inventory

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 15:29 UTC

Monitoring

We have shipped out a fix and are monitoring the results. Please refresh your screen.

If you are continuing to have issues, please reach out to customer support.
Posted Jun 20, 2025 - 15:03 UTC

Identified

We are aware of an issue saving entities (orders, products) that have whitespace in their ID. This was due to an upgrade to one of our libraries responsible for encoding URLs. We are rolling this change back now, and expect the issue to be fixed within the next half hour.
Posted Jun 20, 2025 - 14:38 UTC