Site inaccessible / loading slowly
Incident Report for Finale Inventory
Resolved
This incident has been resolved.
Posted Aug 17, 2022 - 21:05 UTC
Update
Integration tasks are set to be fully online for all customers at 1:57pm Pacific.

Please reach out to customer support if you are continuing to see issues accessing or using Finale.
Posted Aug 17, 2022 - 20:15 UTC
Monitoring
We have identified and addressed an issue caused by the database failover and are slowly re-enabling integration tasks.

The site should be fully working now. We will update this incident when all integration tasks are running again.
Posted Aug 17, 2022 - 20:03 UTC
Update
We have paused all integrations in order to shed load from our database. Once our database normalizes, we will slowly re-enable all integration tasks.
Posted Aug 17, 2022 - 19:34 UTC
Identified
We are continuing to see an abnormally high number of traffic on our database and are investigating ways to mitigate load. Some accounts may see list screens and scanners no longer loading.
Posted Aug 17, 2022 - 19:30 UTC
Monitoring
Between 11:42am until 11:47am, Finale was inaccessible or loading slowly. This appears to have been due to a database failover, which has since resolved itself.

We are continuing to monitor the system to confirm that we are back to normal operations.
Posted Aug 17, 2022 - 19:00 UTC