Amazon push stock integration outage
Incident Report for Finale Inventory
Resolved
Amazon's feed backlog has been resolved. Push stock tasks are are operating normally now.
Posted Oct 08, 2022 - 23:39 UTC
Update
Amazon MWS have updated their status page, they have health operational system again but it may take up to 16 hours to process the ongoing inventory feeds. We continue monitoring our systems while Amazon MWS recovers to normal speed.

Original status from Amazon:
> From 15:46 on 10/06/2022 to 09:20 on 10/07/2022, several Amazon Services were experiencing issues. Service is once again operating at normal capacity at 09:20. Please note that this outage caused a Feed backlog, which may take up to 16 hours to clear. There is no need to re-submit feeds sent during the outage period.

More information can be found at their status page http://status.mws.amazon.com/
Posted Oct 07, 2022 - 16:37 UTC
Update
We are still monitoring our integrations and our partner Amazon MWS has acknowledged the performance issues on their systems. More information can be found at their status page http://status.mws.amazon.com/
Posted Oct 07, 2022 - 15:03 UTC
Monitoring
We are still monitoring and in contact with our Amazon MWS partner in order to resolve the slow push stock incident.
Posted Oct 07, 2022 - 13:48 UTC
Identified
At 06:47pm Pacific, we identified the issue being that Amazon MWS API is not processing our inventory submission feeds responsively enough.
We confirmed the issue is isolated to push stock integration tasks, other Amazon integration tasks are working as expected.
Posted Oct 07, 2022 - 01:52 UTC
Investigating
Starting at 4:43pm Pacific, we observed a significant increase in the number of errors reported on our Amazon push integration for all customers. We are currently identifying the incident root cause and working towards resolving it.
Posted Oct 07, 2022 - 01:29 UTC