Site unavailable
Incident Report for Finale Inventory
Resolved
This incident has been resolved.
Posted Mar 31, 2024 - 08:15 UTC
Update
The system upgrade has completed. Integration tasks will come online over the next hour.
Posted Mar 31, 2024 - 08:15 UTC
Investigating
Due to an unplanned system upgrade, the site is unavailable. We have stopped automated tasks to reduce system load to encourage the system upgrade to complete.
Posted Mar 31, 2024 - 07:44 UTC