Site unavailable due to maintenance

Incident Report for Finale Inventory

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 05:29 UTC

Update

All systems appear to have returned to normal. Integrations will continue to slowly restart over the next hour 50 minutes. During this time, some customers may see their automated integration tasks not running. Manual integration tasks are not affected.
Posted Feb 17, 2025 - 02:23 UTC

Monitoring

Maintenance is now complete. We are monitoring the system as it comes back online.
Posted Feb 17, 2025 - 02:14 UTC

Identified

Scheduled maintenance on our database is taking longer than expected. We are going to stop and slowly restart all integration tasks to shed load from the system while the database recovers.
Posted Feb 17, 2025 - 02:08 UTC