Temporary Pause in Integrations

Incident Report for Finale Inventory

Resolved

This incident has been resolved.
Posted Oct 18, 2025 - 17:06 UTC

Monitoring

We have resumed the integration tasks and continue monitoring the system.
Posted Oct 18, 2025 - 16:13 UTC

Identified

We've identified one of our replica databases in an unhealthy state, which began causing application slowness. To prevent a broader impact, we have temporarily paused all integration tasks and are rebooting the affected database. Integrations will resume shortly, and we are actively monitoring the situation.
Posted Oct 18, 2025 - 15:19 UTC