Degraded performance for automated integration tasks
Incident Report for Finale Inventory
Resolved
The system is back to normal operations. We will continue to monitor system performance over the next week.
Posted Jul 12, 2023 - 00:01 UTC
Update
The system has been restarted. We are continuing to monitor the application as it returns to normal operation.

Automated integration tasks will be fully online around 5pm Pacific / 8pm Eastern.
Posted Jul 11, 2023 - 23:06 UTC
Update
We are beginning our system maintenance now. We will send an update when this is complete.
Posted Jul 11, 2023 - 23:01 UTC
Monitoring
We have been monitoring ongoing issues causing intermittent high latency and integration task disruptions. Customers may see UI requests occasionally taking a long time, and integration delays. This is part of an investigation and mitigation plan to isolate and confirm an ongoing performance issue with one of our critical backend systems.

At 4pm Pacific / 7pm Eastern, we will be restarting the identified system. This will cause Finale to become unavailable for roughly sixty seconds, after which our system should return to normal operation. We believe that after this change, we should see vast improvements in overall system performance and stability.

After we have confirmed a return to stability in our system, we will send out a post-mortem to all customers discussing customer impact, learnings and how we are moving forward.
Posted Jul 11, 2023 - 21:45 UTC