Database outage

Incident Report for Finale Inventory

Resolved

Integration tasks are fully online. This incident should be resolved.
Posted Jun 29, 2026 - 21:51 UTC

Update

We are continuing to monitor the database. Integration tasks are still coming online and database load appears to be back to normal.
Posted Jun 29, 2026 - 21:30 UTC

Monitoring

We have reverted all recently shipped code and have turned on integrations. Integrations will come online over the next two hours. We are continuing to monitor our database during that time.
Posted Jun 29, 2026 - 19:52 UTC

Identified

We have identified an issue affecting our primary database. We have been working to identify the cause and are working to return the application to a working state.
Posted Jun 29, 2026 - 19:34 UTC