User interface errors

Incident Report for Finale Inventory

Resolved

We have resolved the issue and the system is behaving normally as expected.
If you're still facing issues, please try refreshing your browser.

For further inquiries, please contact service@finaleinventory.com
Posted Sep 28, 2023 - 16:53 UTC

Monitoring

We have deployed a fix to the user interface errors while accessing order reports.
If you're still facing issues, please try refreshing your browser.

For further inquiries, please contact service@finaleinventory.com
Posted Sep 28, 2023 - 16:20 UTC

Identified

We have identified the root cause of errors in some of our Report pages. We are already deploying a fix that will be on every account in the next hour.

For further inquiries, please contact service@finaleinventory.com
Posted Sep 28, 2023 - 15:59 UTC

Investigating

Starting today at around 8am Pacific time we noticed that some customers are having problems accessing some of the features in the user interface. In particular, this is affecting a subset of the reports and some of the views related to products. We are working on fixing these issues.

For further inquiries, please contact service@finaleinventory.com
Posted Sep 28, 2023 - 15:42 UTC