Degraded integration performance

Incident Report for Finale Inventory

Resolved

All systems appear to have returned to normal operation.

Please reach out to support (service@finaleinventory.com) if you continue to experience disruptions with your account.
Posted Oct 20, 2025 - 21:52 UTC

Update

We have observed several delays in our job processing code, used for UI imports and our Android scanner. We are still investigating, but are restarting customer accounts to mitigate this issue.

Also, we are still seeing increased latency for several integration partners as well as our cloud provider, AWS. To mitigate the impact of this on our system, we have restarted integration tasks again which will throttle integration task runs over the next hour.
Posted Oct 20, 2025 - 18:39 UTC

Monitoring

We have re-enabled integrations and are not seeing errors.

We will continue to monitor the system as it comes back online to full capacity.
Posted Oct 20, 2025 - 17:56 UTC

Identified

After restarting integrations, we are still seeing errors from many of our integration partners (specifically Amazon, ShipStation, and Shopify). Integration tasks can be triggered manually, but we are disabling automatic integration tasks again until Amazon has resolved the incident on their end.
Posted Oct 20, 2025 - 16:54 UTC

Monitoring

Amazon has provided an update that most services are recovering, see https://health.aws.amazon.com/health/status?path=service-history:

"Oct 20 9:13 AM PDT We have taken additional mitigation steps to aid the recovery of the underlying internal subsystem responsible for monitoring the health of our network load balancers and are now seeing connectivity and API recovery for AWS services. We have also identified and are applying next steps to mitigate throttling of new EC2 instance launches. We will provide an update by 10:00 AM PDT."

We have restarted automatic integration tasks and will continue to monitor them as the system comes back online.
Posted Oct 20, 2025 - 16:25 UTC

Update

Most errors appear to be related to an ongoing incident from AWS, see https://health.aws.amazon.com/health/status?path=open-issues

We are throttling automatic integration tasks at least over the next hour to allow our system to recover.

We will continue to monitor the incident at AWS and restart services as needed.
Posted Oct 20, 2025 - 14:40 UTC

Identified

We are investigating issues affecting report generation, integrations, and barcode scanner syncing. Some customers may experience delays or failed syncs. Our team is actively working to identify the cause and restore normal operation.

For further inquiries, please contact service@finaleinventory.com
Posted Oct 20, 2025 - 13:54 UTC