Server unavailable
Incident Report for Finale Inventory
Resolved
We have pushed fixes and restarted unhealthy servers, the access to accounts is fully restored, performance is good and our monitoring shows no more erros.

For further inquiries, please contact service@finaleinventory.com
Posted Oct 15, 2024 - 13:15 UTC
Monitoring
We have identified failing backend services and have applied solutions, the access to accounts is restored.
We keep monitoring and working on improving the state of the system.

For further inquiries, please contact service@finaleinventory.com
Posted Oct 15, 2024 - 12:52 UTC
Investigating
We’re experiencing technical difficulties.
Our team is working on it and will provide updates shortly

For further inquiries, please contact service@finaleinventory.com
Posted Oct 15, 2024 - 12:24 UTC