Account data load issues
Incident Report for Finale Inventory
Resolved
All accounts are normalized and our monitoring shows no ongoing incidents.

For further inquiries, please message us at service@finaleinventory.com
Posted Jul 20, 2023 - 16:43 UTC
Monitoring
Most customer accounts are loading their full datasets as expected.
We keep monitoring our system for errors and resource usage.

For further inquiries, please message us at service@finaleinventory.com
Posted Jul 20, 2023 - 15:05 UTC
Identified
We have identified some customer accounts failing to load their full datasets, we have already identified a problem and are working on restoring access to all data. No data is lost but the web browsers will not list all data momentarily.

For further inquiries, please message us at service@finaleinventory.com
Posted Jul 20, 2023 - 13:53 UTC