We are currently experiencing a server error
Incident Report for Finale Inventory
Resolved
This incident has been resolved.
Posted Feb 18, 2022 - 16:29 UTC
Update
Issue is being resolved. Load times may be slower than normal.
Posted Feb 18, 2022 - 15:55 UTC
Monitoring
We are experiencing an error. Our engineering team is working on resolving the issue.
Posted Feb 18, 2022 - 14:55 UTC
Update
We are continuing to investigate this issue.
Posted Feb 18, 2022 - 14:53 UTC
Update
We are continuing to investigate this issue.
Posted Feb 18, 2022 - 14:49 UTC
Investigating
We are currently investigating this issue.
Posted Feb 18, 2022 - 14:49 UTC
Identified
We are currently experiencing a server error. Our engineers are working on resolving the problem. Thank you for your patience.
Posted Feb 18, 2022 - 14:49 UTC