We are currently experiencing an issue with our QuickBooks Online integration

Incident Report for Finale Inventory

Resolved

This incident has been resolved.
Posted Jan 27, 2025 - 21:05 UTC

Monitoring

We are currently experiencing an issue with our QuickBooks Online integration. The issue appears to be on QuickBooks Online's side. It is causing our integrations to suddenly get "name in use" errors.
Posted Dec 04, 2024 - 21:11 UTC