Degraded email sending capabilities
Incident Report for Finale Inventory
Resolved
This incident has been resolved.
Posted May 27, 2024 - 14:28 UTC
Update
We are continuing to monitor for any further issues.
Posted May 27, 2024 - 13:49 UTC
Monitoring
Our email provider is experiencing an outage, and as a result email sending capabilities in Finale Inventory are not working. We're monitoring the status of our email provider and will provide updates accordingly
Posted May 27, 2024 - 13:49 UTC