Delays for Amazon push stock integration
Incident Report for Finale Inventory
Resolved
This issue has been resolved since 11pm Pacific (GMT-8).
Posted May 30, 2023 - 10:43 UTC
Update
We are continuing to see delays in inventory update processing for Amazon. Amazon is aware of the issue.

We will keep this incident open until we see Amazon's inventory feed processing latencies return to the normal.
Posted May 29, 2023 - 21:29 UTC
Monitoring
We have observed an increase in push stock latencies for all customers. This can happen when Amazon does not confirm push stock updates from our system within an hour. This means that we are pushing stock less often for the Amazon integration.

We will contact our Amazon partner for additional support, since they are not reporting an issue on their dedicated status page: https://sellercentral.amazon.com/sp-api-status
Posted May 29, 2023 - 17:26 UTC