Site outage
Incident Report for Finale Inventory
Resolved
We have fixed issues with system load and recovered all processes.
Access to accounts and automated integration tasks are back to normal.

For further questions, please message us at service@finaleinventory.com
Posted Jul 21, 2023 - 16:23 UTC
Monitoring
We have identified a major fault on our main database, we working on recovering the system.
Automated integration tasks are recovering and should be at full speed during the next hour.

For further questions, please message us at service@finaleinventory.com
Posted Jul 21, 2023 - 15:46 UTC
Investigating
We have identified a major fault on our main database, we working on recovering the system.
Automated integration tasks are slowed down.

For further questions, please message us at service@finaleinventory.com
Posted Jul 21, 2023 - 15:15 UTC