Billing page unavailable

Incident Report for Finale Inventory

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 13:14 UTC

Identified

We are investigating an issue affecting the billing page. A fix is being worked on now - we hope to see billing back online within an hour.
Posted Aug 15, 2025 - 12:44 UTC