Finale Inventory website is recovered, automated integration tasks are still recovering
Incident Report for Finale Inventory
Resolved
The website and system are recovered and automated integration tasks are running normally.
Posted Nov 18, 2022 - 18:41 UTC
Update
The web application is now working normally, if you still see issues, we would like to ask you to please restart your browser.

Our engineering team is still monitoring our servers and resources to ensure we offer optimal application experience. The automated integration tasks are still restarting and should be up to normal speed in about two hours.
Posted Nov 18, 2022 - 17:23 UTC
Monitoring
We have identified the root cause for our database overload and we have already reverted the code that caused this incident. The automated integration tasks are restarting and they may take up to two hours to be back at normal speed.

The web application is already working normally, if you still see issues in the web application, we would like to ask you to please restart your browser.

Our engineering team is monitoring the application logs and ensuring the application goes is fully working as expected.
Posted Nov 18, 2022 - 16:56 UTC
Identified
Today at 07:42 PT we detected an overloaded in our database, which is causing unresponsive UI for some customers.
We have identified recent code that is causing issues and we are restarting our systems to normal state. Automated integration tasks are currently stopped.
Posted Nov 18, 2022 - 16:05 UTC