Etsy push stock is down

Incident Report for Finale Inventory

Resolved

This incident has been resolved. It may take up to 24 hours to fully return to normal due to Etsy having Daily API rate limits.
Posted Oct 01, 2025 - 01:53 UTC

Identified

Currently testing a fix for the issue.
Posted Sep 30, 2025 - 21:51 UTC

Investigating

We are currently investigating the issue. Starting Monday September 30th at 11:41 AM PT, push stock tasks started failing to update listings. This was caused by a change on Etsy's side. Etsy's API started telling us that the reason our update requests are failing is that "All offerings need readiness state".
Posted Sep 30, 2025 - 15:44 UTC