Investigating degraded performance
Incident Report for Finale Inventory
Resolved
Access to the application is fully restored and degraded performance was resolved.
Automated integration tasks are at 50% speed and recovering, will soon be up to full speed.

For further inquiries, please message us at service@finaleinventory.com
Posted May 13, 2024 - 14:36 UTC
Identified
We have restarted automated integration tasks, those will take up to an hour for normal speed.
We are still ensuring the system resources are correctly handled and access to the website is maintained.

For further inquiries, please message us at service@finaleinventory.com
Posted May 13, 2024 - 14:09 UTC
Investigating
We are investigating issues with our application overloading and impeding access to customers. Automated integration tasks were paused and we are working towards bringing the system back to healthy state.

For further inquiries, please message us at service@finaleinventory.com
Posted May 13, 2024 - 13:30 UTC