All Systems Operational
Past Incidents
May 9, 2024

No incidents reported today.

May 8, 2024

No incidents reported.

May 7, 2024

No incidents reported.

May 6, 2024

No incidents reported.

May 5, 2024

No incidents reported.

May 4, 2024

No incidents reported.

May 3, 2024

No incidents reported.

May 2, 2024

No incidents reported.

May 1, 2024

No incidents reported.

Apr 30, 2024

No incidents reported.

Apr 29, 2024

No incidents reported.

Apr 28, 2024

No incidents reported.

Apr 27, 2024

No incidents reported.

Apr 26, 2024
Resolved - This incident has been resolved.
Apr 26, 17:54 UTC
Update - We've identified and fixed an issue caused by a backend system that affected around 60 customers this morning. This issue caused recently created/updated orders, products, and other entities to become missing from the Finale application. We are restarting processes over the next two hours which will fully resolve this incident for all affected customers.

If you notice missing entities from Finale (orders, products, lookups, etc.) please contact support@finaleinventory.com - we can expedite this fix for customers who still see issues on their account.

Apr 26, 17:45 UTC
Monitoring - We have started automated integration tasks, this will take about two hours to be up to full speed.
For further inquiries, please contact service@finaleinventory.com

Apr 26, 16:17 UTC
Update - We are starting the recovery process of synchronization issues and are planning on starting automated integration tasks soon.

For further inquiries, please contact service@finaleinventory.com

Apr 26, 15:50 UTC
Identified - We have identified synchronization issues within our databases, which is leading to some customers seeing outdated information.
We are stopping the automated integration tasks.
For further inquiries, please contact service@finaleinventory.com

Apr 26, 14:23 UTC
Apr 25, 2024

No incidents reported.